
MACROMEDIA FLASH 8                                                                        SESSION 4 

 
 
 
 

SESSION 4: FX ANIMATION 

1. MOTION GUIDE 

TUTORIAL GERAKAN MELINGKAR 
 
Animasi jalur atau Motion Guide Tween adalah objek yang bergerak mengikuti 
suatu jalur tertentu yang telah ditentukan pada layer guide. 
 
Jadi animasi jalur menggunakan 2 buah layer, yaitu layer untuk objek dan animasi 
(Layer 1) dan layer untuk guide (Guide: Layer 1). Garis guide bisa dibuat 
menggunakan Pen tool, Line tool, Pencil tool, Rectangle tool, atau Oval tool. 
 
Pada latihan ini, kita akan membuat lingkaran yang bergerak berkeliling mengikuti 
garis orbit. 
1. Klik Oval tool, lalu gambar lingkaran kecil di layar. Ubah menjadi simbol: 

Graphic. 
2. Klik menu Insert > Motion Guide, akan muncul layer baru di atas Layer 1 

dengan nama Guide: Layer 1. 

 
 
3. Pindah ke layer Guide: Layer 1, lalu gambar lingkaran besar menggunakan Oval 

tool, aturlah bidang tanpa warna dan pinggir hitam. 
4. Klik Eraser tool untuk memotong bagian bawah lingkaran. 
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5. Setelah garis terbentuk, klik frame 30 lalu Insert Frame. 
6. Pindahkan ke layer 1, lalu pindahkan lingkaran kecil ke awal garis. Ketepatan 

letak lingkaran pada awal garis ditandai dengan cincin saat proses pemindahan. 
(Apabila cincin tidak terlihat, coba klik menu View > Snap to Objects). 

 
7. Klik pada frame 30 lalu klik Insert Keyframe. 
8. Masih di frame 30, pindahkan lingkaran kecil ke akhir garis. Perhatikan ketepatan 

letak lingkaran pada akhir garis ditandai dengan cincin saat proses pemindahan. 

 
 
9. Klik frame 1 untuk kembali ke frame 1, lalu pada Properties pilih bagian 

Tween: Motion. Jalankan animasi. 

ANIMASI MOTION GUIDE MENGGUNAKAN HURUF 
Dalam pembahasan kita kali ini, kita akan membahas teknik animasi menggunakan 
motion guide. Dimana nantinya kita akan membuat tulisan berjalan berkelok – kelok. 
Untuk lebih lanjut bagaimana langkah – langkah membuat animasi motion guide 
menggunakan huruf berikuta adalah langkah – langkah nya : 
 

1. Buatlah Movie baru dengan Framerate nya 25 fps dalam aplikasi 
Macromedia Flash 8. 
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2. Pada layer1 ubah namanya menjadi Objek A, pilih Teks Tool    Ketik A 
pada jendela movie lalu pada jendela properties pilih opsi sebagai berikut : 

 
a. Font= Arial ,  b. Font Size = 30 , c. Teks Fill = #000000 

 
 
 
 
 
 
 
 
 
 
 
 

Pengaturan Teks pada jendela properties 

 
3. Klik kanan pada objek A pilih Convert To Symbol, Dalam jendela Convert 

To Symbol pilih opsi sebagai berikut : 
a. Name  = A 
b. Type  = Movie Clip 
c. Registration = Pilih titik Pinggir kiri atas 

 

 
 
 
  

Kotak dialog Convert To Symbol dengan name nya A 

 
4. Tambah Layer baru ubah nama nya menjadi Objek O, pilih Teks  

5. Tool    ketik O pada jendela movie lalu pada jendela properties 
pilih seperti gambar1. 

 
6. Klik kanan pada objek o pilih Convert To Symbol, Dalam jendela Convert 

To Symbol pilih opsi sebagai berikut : 
 

a. Name  = o 
b. Type  = Movie Clip 
c. Registration = Pilih titik pinggir kiri atas 
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Kotak dialog Convert To Symbol dengan name nya o  
 

7. Ulangi langkah No.4 dan 6 ganti teks dengan 8, o, T dan ubah Layer nya. 
8. Pada jendela Timeline pilih Add Motion Guide. 

 

 
 

 
 

Add Motion Guide pada jendela Timeline 

 
9. Atur Posis layer dengan cara di Drag menjadi seperti gambar dibawah ini : 
 

 
 

 
  
 
 
 
 
 
 
 
 
        Posisi layer sebelum di atur Posisi layer sesudah diatur 

 
 

8.   Pada Layer Motion Guide pilih Pen Tool   , dan pada Option  pilih 
smoot. Buatlah garis melengkung dalam jendela Movie, seperti gambar 
dibawah ini. 

     
.Kotak Option pada 
jendela Tools 
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    garis melengkung menggunakan Pen Tool. 
 
 
 

9. Pada Frame120 di Layer A, 8, o, T, o  Klik kanan pilih Insert Keyframe, 
sedangkan pada Layer Motion Guide di Frame120 Klik kanan pilih Insert 
Frame. 

10.  Pada Layer A,o,8,o,T klik kanan pilh Create Motion Tween. 
11. Di frame1 pada objek A,o, 8, o, T atur posisi objek nya tepat di ujung 

depan garis, dengan menggunakan Free Transform Tool  seperti 
gambar dibawah ini : 

 

 
 

 
Posisi objek A,o,8,o2,T pada Frame1 
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12. Pada Layer A, 8, o2 di Frame1 pilih Snap To Objects pada jendela 
properties chek list pada Orient to Path. 

 

 
 
 
 

Orient to path pada jendela properties. 

 

13. Pada Layer o dan T di Frame1 pilih Snap To Objets  pada jendela 
properties chek   list pada Orient to path, Sync, Snap. 

14. Di Frame120 pada objek A,o, 8, o2, T atur posisi nya tepat di ujung 

belakang garis, dengan menggunakan Free Transform Tool  seperti 
gambar di bawah ini. 

 

 
 

Posisi objek A,o,8,0,T pada Frame120 
 
 

15. Animasi siap dijalankan dengan menekan tombol Ctrl + Enter. 
 

2. MASKING 
 
Animasi Masking adalah animasi objek yang menutupi objek lain, sehingga objek 
yang menutupi terlihat transparan. 
 
Pada latihan ini, kita akan membuat objek tulisan yang akan terlihat apabila 
tertutupi oleh objek kotak segi panjang. Kemudian kita akan menambil suara yang 
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sudah tersedia dalam Flash di Common Libraries Sounds-nya, dan 
menyisipkannya dalam animasi kita. Penggunaan suara dapat menambah daya tarik 
pada animasi. 
1. Klik Text tool, lalu tulislah ‘MASKING’ di layar. 
2. Klik pada frame 40, lalu klik kanan dan pilih Insert Frame. 
 
3. Klik menu Insert > Layer (atau klik pada tanda plus di panel Timeline) untuk 

membuat layer baru. Sekarang kita punya 2 buah layer, yaitu Layer 1 dan Layer 
2. 

 

 
 

Add layer 
 
4. Klik Layer 2 untuk berpindah layer, lalu klik Rectangle tool untuk gambar segi 

panjang diatas teks. Lebar dan panjangnya disesuaikan dengan ukuran teks. 

 
Kotak segi panjang di atas teks 

 
5. Pilih kotak segi panjang lalu ubah menjadi simbol: Graphic. 
6. Klik pada frame 20, lalu masukkan Keyframe. Lakukan hal yang sama pada 

layer 40. 
7. Klik frame 20 lagi untuk kembali ke frame 20, lalu pindahkan kotak ke bawah 

teks. 
 

 
Kotak segi panjang di bawah teks 

 
8. Klik pada frame 1, lalu pada Properties pilih bagian Tween: Motion. Lakukan 

hal yang sama pada frame 20. 
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9. Kemudian, klik kanan pada Layer 2, lalu pilih Mask. 

 
 

Pemberian efek Mask pada Layer 2 
 
10. Terakhir, tambahkan suara. Klik menu Window > Common Libraries > 

Sounds, akan muncul pilihan suara. 
11. Setelah kita memberi efek Mask pada layer, biasanya layer-layer tersebut akan 

terkunci (ditandai dengan gembok pada layer). Klik pada tanda gembok untuk 
unlock supaya kita dapat mengedit. 

 

 
Unlock layer 

 

3. FLASH HACKING 

1. Merubah Format SWF Ke FLA menggunakan SWF Decompiler 
 
Setelah kita memahami dasar –dasar penggunaan SWF Decompiler diatas, kini kita 
akan mempelajari bagaimana mengconvert Format SWF ke Format FLA. 
Yang harus pertama anda lakukan adalah mempunyai Format SWF untuk 
mengconvert ke Format FLA berikut langkah –langkah nya : 

 
1. Buka Program SWF Decompiler. 
2 Dalam Explorer buka Format SWF yang ingin  dijadikan Format FLA. 

( Dalam Latihan kali ini kita menggunakan Be you SWF yang disertakan dalam 
CD latihan ). 

3. Dalam Menu Utama pilih File > Export FLA atau tekan F4 atau juga dalam      
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Toolbar pilih menu Export FLA. 
 

                                                   
         
 Simbol Export SWF Ke FLA 

 
 Maka akan muncul kotak dialog Save As. 
 Dalam kotak dialog Save As Pilih Save untuk menyimpan File yang 

sudah dijadikan FLA.  
 

                   
                 G

   Tampilan Kotak Dilaog Save 
 

4. Convert Format SWF ke FLA selesai. 

2. Mengedit Tulisan dalam Format SWF Ke FLA 
Dalam topik bahasan diatas diharapkan pembaca sudah dapat mengerti bagaimana 
cara mengconvert Format SWF Ke FLA dengan meggunakan SWF Decompiler. Dan 
sekarang kini kita akan latihan bagaimana cara mengedit suatu Format SWF yang 
sudah di convert menjadi FLA. 
 
Untuk pembahasan kali ini kita akan mengedit suatu tulisan yang ada di dalam 
Format SWF yang sudah diconvert menjadi FLA. 
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                               Sebelum di Edit                                                                              Sesudah di Edit 

1. Buka Aplikasi SWF Decompiler 
2. Dalam File explorer Buka File Be You.SWF  yang disertakan didalam CD 

latihan kedalam aplikasi SWF Decompiler 
3. Convert menjadi Format FLA, dengan menekan Export FLA yang ada di 

dalam Tool bar SWF Decompiler. 
4. Simpan dengan File Name nya Be You FLA. 
5. Buka Aplikasi Macromedia Flash 8 
6. Tampilkan Be you fla yang sudah di convert melalui SWF Decompiler  
7. Dalam jendela Timline pada Layer 11 ( yang mana Layer 11 adalah teks yang 

kita edit ). 
 

 pilih frame 123 dan blok hingga ke Frame 110. 
 Klik kanan pilih Clear Keyframe. 

 

        
 

Tampilan Frame yang diblok 
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8. Dalam Layer 11 pada Frame 110 tekan F6. 

9. Masih dalam Layer 11 di frame 110 Pilih Teks Tool    lalu buat teks 
Jangan kehilangan dirimu dalam jendela Properties pilih opsi berikut : 

 
 Font  :  Time New Rowman     
 Size  :  17  
 Style   :  Bold  
 Align       :  Center  
 Text Fil    :  #1E79E7 

10. Pilih teks Jangan kehilangan dirimu dengan menggunakan Selection Tool 

, kemudian dalam Menu utama pilih Window > Align atau menekan 
CTRL + K dalam kotak dialog Align Pilih Opsi : 

 

 
Gambar 1.7. 

Tampilan Kotak Dialog Align 
 

1. Dalam To Stage Pilih tombol Align/Distribute To Stage. 
2. Dalam Align pilih tombol Align Horizontal Center 
3. Dalam Distribute pilih tombol Distribute Vertical Center 

11. Kemudian Pilih teks Jangan kehilangan dirimu dengan menggunakan 

Selection Tool   lalu tekan F8, pilih Movie clip dan beri Nama edit_teks. 
12.  Dalam Layer 11 pada frame 123 tekan F6 
13.  Di Layer 11 antara frame 110 s/d 123 klik kanan pilih create motion tween 

. 
14. Klik frame 110 pilih  teks Jangan kehilangan dirimu, dan di jendela properties 

pada opsi Color pilih Alpha beri nilai 0 %. 
15. Masih pada Layer 11 pada frame 124 tekan F6 
16. Tekan CTRL + Enter untuk melihat hasil movie nya. 

3. Mengedit Gambar dalam Format SWF Ke FLA 
Dalam pembahasan yang ke-dua, pembaca akan mendapat latihan bagaimana 
mengedit suatu Gambar dalam Format SWF Ke FLA dengan menggunakan SWF 
Decompiler. Dan dalam Latihan kali ini  diharapkan pembaca sudah memahami 
tentang bagaimana cara mengedit suatu Tulisan dalam Format SWF ke FLA dengan 
menggunakan SWF Decompiler yang sudah dibahas diatas. 
 
Berikut adalah contoh pengeditan gambar dalam Format SWF yang sudah diconvert 
menjadi Format FLA. 
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                                  Sebelum di edit                                       Sesudah di edit 
 
1. Buka Aplikasi SWF Decompiler. 
2. Dalam Explorer cari Format SWF yang ingin dijadikan Format FLA  

( Pada Latihan kali ini kita menggunakan ngajari SWF yang   disertakan dalam 
CD latihan ). 

3. Dalam menu utama pilih File > Export FLA atau tekan F4 atau bisa juga dengan 
menekan Export FLA yang ada di dalam Tool bar SWF Decompiler. 

 

 
 

Simbol Export SWF Ke FLA 
 

 Maka akan muncul kotak dialog Save As. 
 Dalam kotak dialog Save As pilih Save untuk menyimpan File yang 

sudah dijadikan FLA. 
 Simpan File Anda 

 

 
 
Tampilan Kotak dialog Save 

 
4. Convert Fomat SWF ke FLA selesai. 
5. Buka Aplikasi Macromedia Flash 8 
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6. Tampilkan ngajari FLA yang sudah di convert melalui SWF Decompiler 
7. Dalam Jendela Timeline pada Layer 1 di Frame 1 Delete gambar ngajari. 
8. Pada menu File pilih Import > Import To Library  

 Pada kota dialog Import To Library cari gambar Mata yang 
disertakan dalam CD. 

 Pilih  Open untuk membuka nya di aplikasi Macromedia Flash  
 Tekan F11 atau pilih menu Window > Library untuk menampilkan 

gambar Mata  
 Drag gambar mata kedalam layar kanvas 

9. Kemudian tekan CTRL + K atau pilih menu Window > Align. 
1) Dalam kotak dialog Align pilih To Stage 
2) Pada Align pilih tombol Align Left Edge. 
3) Kemudian pada Distribute pilih Distribute Top Edge. 

 

 
 

Kotak Dialog Align 
 
10. Pengeditan telah selesai untuk melihat  Movie nya tekan tombol CTRL + Enter. 
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